Peu commune · Savoirs
Mailto
mailto: est un schéma d'URI permettant de créer un lien hypertexte vers une adresse électronique. Employé par exemple dans une page web en HTML, un tel lien permet à l'utilisateur qui l'a suivi de voir son client de messagerie démarrer l'écriture d'un nouveau message électronique, avec quelques champs déjà remplis, comme l'adresse du destinataire ou encore l'objet du message.
Sur Wikipédia
mailto: est un schéma d'URI permettant de créer un lien hypertexte vers une adresse électronique. Employé par exemple dans une page web en HTML, un tel lien permet à l'utilisateur qui l'a suivi de voir son client de messagerie démarrer l'écriture d'un nouveau message électronique, avec quelques champs déjà remplis, comme l'adresse du destinataire ou encore l'objet du message. mailto: a été défini par plusieurs RFC : la première fois en décembre 1994 par la a RFC 1738, puis mis à jour en juillet 1998 par la RFC 2368, qui a été finalement remplacée en octobre 2010 par la RFC 6068. Extrait de la syntaxe de l'URI dans la norme : où to est donc une ou plusieurs adresses courriel addr-spec de destinataire (séparées par une "," littérale (ou un ";") et ne comprenant chacune aucun caractère parmi ",", ";", "?", "&") et hfields les autres champs (séparés du champ to par un "?" littéral, ces champs étant séparés entre eux par un signe "&" et comprenant chacun deux parties : un nom symbolique de champ (hfield) ne comportant que des lettres ("from", "to", "cc", "bcc", "subject", "body") et une valeur (hfvalue) donnée à ce champ (qui dans le cas des champs nommés "from", "to", "cc" ou "bcc" peut également donner une ou plusieurs adresses courriel séparées par une "," ou un ";" ). Le champ explicitement nommé "to=..." peut remplacer le premier champ facultatif to, ou le compléter en donnant des adresses de destinataires supplémentaires. L'intégration de mailto: dans une balise HTML utilise le format suivant :
Texte : Wikipédia, CC BY-SA 4.0. ·