Rara · Literatura
QUIC
Capa de Transporte experimental de protocolo de red para ordenadores basado en el Protocolo de Datograma de Usuario
QUIC es un protocolo de red sobre la capa de transporte diseñado por Jim Roskind en Google, inicialmente implantado en 2012, y anunciado como experimento ampliado en 2013. QUIC soporta un conjunto de conexiones multiplexadas entre dos extremos sobre UDP (User Datagram Protocol), y fue diseñado para proveer seguridad equivalente a TLS/SSL, junto con latencia de conexión y de transporte reducidas, y estimación de ancho de banda en cada dirección para evitar la congestión.
Leer más
El principal objetivo de QUIC es mejorar el rendimiento percibido de aplicaciones web orientadas a conexión que usan actualmente TCP. También proporciona un entorno para la iteración rápida de algoritmos de prevención de congestión, estableciendo control en el espacio de aplicación en ambos extremos, en lugar de hacerlo en el (lento de actualizar a nivel de cliente) espacio kernel. En junio de 2015, un borrador de trabajo (Internet Draft) sobre una especificación para QUIC fue presentado al IETF para su estandarización. En 2016 se estableció un grupo de trabajo de QUIC. En octubre de 2018, los Grupos de Trabajo HTTP y QUIC del IETF decidieron conjuntamente llamar "HTTP/3" al mapeo HTTP sobre QUIC antes de convertirlo en un estándar mundial. En mayo de 2021, el IETF estandarizó QUIC en RFC 9000, respaldado por RFC 8999, RFC 9001 y RFC 9002. Se quiere reducir la latencia a lo largo de todo Internet, proporcionando un conjunto de interacciones de usuario más receptivo. A medida que pase el tiempo, el ancho de banda irá creciendo, pero el tiempo de intercambio de mensajes, al depender de la velocidad de la luz, no podrá variar en sí mismo.
Texto: Wikipédia, CC BY-SA 4.0. · Imagen: xchiamiov (CC BY 2.0) ·